Voyage Online Today: 0    Total Posts: 98771


Create Thread

[Discussion] [Solved] Broken story line again??? #67-68 (guild join bug???)

Close [Copy link] 12/3795

Posted on 2018-01-03 13:05:10 | Show thread starter's posts only

Thread Synopsis:
Characters made before 1/2/2018 would have the quest line break at #67
Easiest solution : just make a new alt, it works fine with characters created after the 1/2/2018 update.

*edit May 2020
I now believe this was the first occurrence of the story-line breaking due to joining a guild though that is not specifically written in this thread the old alts were not able to do the quest-line..unfortunately no way to know now if old alts were in a guild or not... but others said it worked fine... so is highly likely.
That means this broke with the the patches or missing patches that occurred sometime between December 26, 2017 and January 2, 2018 (patch numbers 0.128, 0.129, 0.130) which included the save Santa event patch and closing the voyage log christmas event. (Sea general cards also began to show stats but still didn't work at this time)


Hello people ,

As title says i believe Main story line is broken again. I just finished step ( quest ? ) 67 and step 68 did not pop up. 

Maybe this is one more thing that patch broke up :D

Anyway if someone else can check it also that would be great . ( i have already tried with 3 alts all stopped at same spot. Step 67 )

Posted on 2018-01-03 13:11:24 | Show thread starter's posts only

Did you follow this guide?


Navigator, tools, guides and much more!
Visit us at:
Posted on 2018-01-03 13:12:12 | Show thread starter's posts only

That is a new place for the story line to "break"
this quest is auto completed as soon as you stop auto running to/ or click on the NPC Andrews (if I remember correctly)

You should have auto started the next task.
Check your Voyage Log to be sure where you are in the quest line.
Be 100% sure the quest line did not change the tab in the voyage log it is displayed on.

I am guessing Tataduk knows about the Beginners Guide as he reports #67 as broken...
but I have copy pasted the actual quests so that others reading will know what #67 refers to, along with the quests prior and after for easier reference on exact number it is broken at.

66. Misunderstanding
Return to Genoa Port
Task automatically turns in when you land on Genoa dock. (You may have to wait a few seconds)
Reward (Voyage Log):  Prof Exp 4,400,000, Voyage Exp 400,000, Eloquence 200,000
Reward (chat): Prof Exp 50,000,000, Voyage Exp 400,000, Eloquence 200,000

67. Hard Work Paid Off
Talk to Andrews in Genoa City**You Have to use the voyage log to auto track for this task.
Reward (Voyage Log): Prof Exp 3,800,000, Purple Badge (ordinary) lvl 53 Land Jewelry
**NEW**Reward (chat): Prof Exp 50, 000,000, Dark Gold Badge (Superior) lvl 93 Land Jewelry, 60 Original Magnetic Ore

*** At this point I reached level 100
(which is new as of the June 2017 update) ***

68. Acknowledgment
Talk to the Merchant Alliance officer of your alliance.
**You can now choose which Merchant alliance officer to Auto track to. Click one of the 5 underlined destinations   You will need to know what alliance you joined
ckick Cntrl+X > Merchant Alliance Tab > Alliance appears in BIG YELLOW LETTERS
in my case it is the Nederlands Alliance


Reward (Voyage Log): Prof Exp 5,100,000, Silver 200,000,  Merchant Alliance Contribution 200
Reward (chat):  Prof Exp 40,000,000, Silver 200,000, Merchant Alliance Contribution Certificates 20

You can find your MA officer here:
Alexander- Islandi (57, 60)
Venice- Western Mediterranean  (50,-22)
Lisbon- Iberian (10,20)
Bordeaux- English Channel (56,66)
Amsterdam- Nederlands (50, -20)

69. Ask For a Battle Assignment
Talk to the Seville Tavern Boss.
Reward (Voyage Log): Prof Exp 3,900,000
Reward (chat): Prof Exp 40,000,000

***While you are on the top level in Seville, visit the Fee Gear Giver (18, 27) and get as many rewards as you can. You get rewards for reaching lvl 30, 60, 90, 120.  You get 1 - Lethe tool, 1 unlock tool ( cabin ),  1 unlock tool ( Bag ), for each reward.

Posted on 2018-01-03 13:18:46 | Show thread starter's posts only

Posted on 2018-01-03 13:26:37 | Show thread starter's posts only

Posted on 2018-01-03 13:34:51 | Show thread starter's posts only

I started a new sequence of 5 alts yesterday after the maintenence and the 0.130 patch and its all ok for me on all 5 alts.

I am currently at step 98, I follow the guide step by step, so I dont think its a bug... Will start a new sequence tomorrow, and will let you guys know if it is still ok for me.

Posted on 2018-01-03 14:23:32 | Show thread starter's posts only

ok only thing i can think is maybe you tried all 5 alts w/ out re logging game?
and that 1 piece of info didn't get loaded at that time.

I am assuming you have re-logged your bugged accounts  but have your rebooted computer as well  just to be sure.

after that all I can say is contact support

you might have to do a reinstall of game as update seems to have messed up a file somewhere if it is working for other people but not you.
(which would explain all 5 characters)

warning there is no manual update yet... so be sure to reinstall as admin.

I am not sure that will solve the problem or not...
you may then have to contact support
but at least you now have proof that the quest dissappeared
not sure why you wold purposely break 5 characters worth but what ever...

IGG Customer / Client Support Links; contact info

- ele

Posted on 2018-01-03 17:45:09 | Show thread starter's posts only

Great, that's a new one, it never broke on that task before. Is there anything that's not broken these days?


Navigator, tools, guides and much more!
Visit us at:
Posted on 2018-01-03 22:54:17 | Show thread starter's posts only

I started a new character but only made it to #31 First Voyage (Seville docker).. will do more tomorrow.

Posted on 2018-01-04 05:25:36 | Show thread starter's posts only

I had an alt that was in no 60 of story line
I made the rest tasks Ann faced the same problem

If you start the line from task not  after the last patch it's working

Tara DO NOT reinstall the client