Voyage Online Today: 1    Total Posts: 98671


Create Thread

[Discussion] [Solved] Game not loading after install

Close [Copy link] 3/561

Posted on 2021-02-21 12:11:49 | Show thread starter's posts only

I have a question regarding the game for European users. I played for last time this game in 2014 and I had a good account but now when I install the game it isn't loading. Is it because I am in Europe or what can be the reason? I will be happy if I can play it again.

Thank you!


changed title to reflect actual problem  - Ele

Posted on 2021-02-21 17:27:04 | Show thread starter's posts only

First;  Always run/ start the game as Administer - or it wont go through the checking for updates (which is sometimes broken- explained further down in this thread) - and if it can not check for updates the game will not run (it may give an error but I don't remember what it says exactly).

There are several ways to run as admin -
I suggest making a desktop shortcut and making/ changing the shortcut properties so that shortcut always starts the game as admin.

for one time/ each time use:


2nd;  it doesn't matter what country you are in a download is a download. (unless you have a very bad connection and you get data pack loss)

3rd; because you haven't played in so long you will need a total new version of the game.
so that no old file gets used with the new ones;
manually delete - one by one - the old VCO files.  No program will remove the game files not even windows.
then run a file cleaner to get any leftover fragments.

(you may want to save some of the old screen shot files first IDK)


What does matter is that you are getting all the files loaded and in the correct order.

We are actually currently using version .150 Not .149 as written on the down load page.
different links will give you different versions so pay attention when the game downloads and see what version you got.

then go to the " latest patch download" section and down load the patches you need.

The patches ARE NOT in order .....(see below)

so If you used the main down load link ("Download official Downloader" ) - which should give version .149 (hopefully)... after it stops then immediately down load  the "[US] 0.149-0.150 patch download 12"
if you used the uTorrent download "[US] Game client version 0.148 seed 1" you would then need to use 2 patches ; "[US] 0.148-0.149 patch download AND [US] 0.149-0.150 patch download 12".

(no, i have no idea why the "download 12 or 13 or 7 etc.." is written, because all it does is confuse people)

In theory if you start the game as administer after downloading version .149 it SHOULD then update to version .150.
HOWEVER in the recent past we have had problems where if 2 update files were needed, one file would not load, only the latest one would upload.

So to be sure you get all the files AND IN THE CORRECT ORDER just download all game files manually.


Do not forget to RE-ACTIVATE your old game (account) it is different/ stored on entirely different servers than the IGG account you used to post here in the forum:

- Ele

Posted on 2021-02-22 19:29:26 | Show thread starter's posts only

Thank you very much xanthian31!
It worked!
Wish you all the best!


Posted on 2021-02-23 15:22:38 | Show thread starter's posts only

Glad it worked

marking as solved and locking

- ele