Voyage Online Today: 7    Total Posts: 97608

Total:#4

Create Thread

[Discussion] Game freezes when I move mouse

[Copy link] 3/133

#1
Posted on 2021-01-07 11:44:23 | Show thread starter's posts only

Hi guys, I have this problem that when i move the mouse the game literally freezes, but when I dont move it, it runs completely normal. Anyone else had the same issue and fixed it please? Thanks.

--------------
put a more complete description in title for search purposes - Ele

Signature
#2
Posted on 2021-01-07 11:55:01 | Show thread starter's posts only

If you're using NVidia graphic card, and if you downloaded the new drivers for it, downgrade it to November, the new drivers have a problem and whenever you move the mouse, the game starts to lag like shit.

Signature
#3
Posted on 2021-01-07 14:54:59 | Show thread starter's posts only

from other threads with the same subject:

1) Try checking your graphic card settings. Try messing up a little with anisotropic filtering and antaliasing. It might solve the problem.

Update your graphics card drivers... (or as above use old one)

Re-install them if u have the latest version.

Try updating your mouse driver if that doesn't work, try using a different mouse driver that is compatible.

2) Turn off Power saving mode.
"easy i was opening the power saver mode which seemly use a low no. of cpu usage to save power and i was having a great lag on mouse moving when i changed to high performance in changed the lag to a little lag 6-10 FPS which is not bad"

3) Try changing out the drivers to a stable build ( ATI drivers are 13.11 Beta 9)...."Right on. I tried 13.9 (stable) and kept the same problem, took the driver down to 13.4... and it works perfectly".
.."yea i try to stay clear of anything beta just for that reason"

see this thread for other attempted fixes: Mouse Movement causes frame drop

4)  We used to change it by editing the vidicon.ini (game file on your computer) by changing the MaxDistance option. Not sure if you can get that to work now since the file is encrypted

5) I didn't find a complete fix for it, but only a temporary one. As it appears, my mouse polling rate was set to 1000. I've reduced it down to 125. I still experience FPS drop, but its no longer that intensive anymore. It only drops from 120 to 95 FPS, even if I move the mouse around like a lunatic.

- Ele

Signature
#4
Posted on 2021-01-08 11:26:38 | Show thread starter's posts only

I had dozen of people asking me about the problem. Do what Vyndanth said, rollback your drivers to an earlier version, pre december.

Signature

Navigator, tools, guides and much more!
Visit us at: https://thepiratescove.org