Voyage Online Today: 0    Total Posts: 95474

Total:#5

Create Thread

[Discussion] Need help downloading the game!

[Copy link] 4/102

#1
Posted on 2020-03-21 10:28:15 | Show thread starter's posts only

I have been trying to download this game for a few days now and nothing is working! Whenever I try to install it I get a bunch of error messages (I will post them so you can see). Also I can't install it through the HTTP method either. I'm running Windows 10 on a Predator Helios 300 that is less than a month old so I really don't know why I keep getting these errors. 

Any help is appreciated! 

*sorry for the image size*

Signature
#2
Posted on 2020-03-21 10:35:25 | Show thread starter's posts only

I quote from other player having same problem, and this help him:

"After many hours and many attempts about how to pass the error according Microsoft Visual C++ Runtime Library error message I installed the patch [US] 1.40 - 1.41 patch download 3 and somehow the game run correctly. "

Signature
#3
Posted on 2020-03-21 12:43:59 | Show thread starter's posts only

If you downloaded the last client version 0.141, then its possibly due to administrator permissions.

When installing the game, right click the setup file and run as administrator.
When running the game, right click voyage century icon and run as administrator.

Additionally, add voyagecentury.exe to windows firewall exception list. Also make sure antivirus software is off when installing the game. We had issues where it messed up the installation for some players.

Signature

Navigator, tools, guides and much more!
Visit us at: http://thepiratescove.org
#4
Posted on 2020-03-21 14:21:48 | Show thread starter's posts only

as the same problem seems to be encountered by new players/ downloads... here are a few pictures to use should the problem occur again:


We are currently on version .141


the main down load of the game only installs version .137


so you need to install both the patches below along with (immediately after) your main download!

In theory when you start the game (as administer) is should download BOTH patches... however it obviously is not doing that right now. (it might be only installing .137-.140 at start up, as the player above mentioned he only needed to install the .141 patch)


All VCO downloads are located at: http://vc.igg.com/download/client.php


- Ele

Signature
#5
Posted on 2020-03-21 16:08:23 | Show thread starter's posts only

Thank you all so much, I got it to work!

Signature