Voyage Online Today: 3    Total Posts: 91560

Total:#6

Create Thread

[Discussion] [Solved] GPU problem on laptop

[Copy link] 5/432

#1
Posted on 2019-03-26 13:44:14 | Show thread starter's posts only

I have a laptop with Intel(R) HD Graphics 630 and NVIDIA GeForce GTX 1060 with Max-Q Design in it, and running game under win 10. My issue is VCO usues my integrated graphics instead of Nvidia. I only have probelm with VCO, other games running well. I googled this problem, it can happen with older games, but i didnt find solution works for me. 

Settings i have already tried:

- Changed global 3D settings on Nvidia control panel to use Nvidia always, also program settings, including core.exe, also directy run the program with nvidia

- Every power settings to high performance

- Win 10 graphics settings manually for vco, high performance

- Updated intel and nvidia drivers to latest, even reinstalled whole win 10, VCO multiple times

- Disable intel not works, cause they work together in laptops, integrated is for display, videos and such, disable is disable nvidia too.

Its annyoing, game not smooth enough ofc on integrated, and opening more clients make it running on its max capability and lag, when Nvidia is there doing nothing. 
Thank you in advance if anyone can help, or had same issue, and found solution.

Signature
#2
Posted on 2019-03-26 14:39:50 | Show thread starter's posts only

Hi,

Recently friend bought new laptop with pretty much same issue as you've described. Some of older games don't work as expected on such powerful machine.

He managed to run it at full potential only when AC adapter is plugged in(among with High Performance Power Settings).

You must choose NVIDIA card for specific application in order to use that GPU to start it.
Which you already did, but... You wrote there only core.exe file...
 
You have Core.exe in VCO directory and Core.exe which is located in voyage directory, inside your default directory. Have you tried setting both of those to run on NVIDIA GPU?

Also, as I wrote above, try running it with AC Adapter plugged in.

Signature
#3
Posted on 2019-03-26 16:18:45 | Show thread starter's posts only

Same issue here, and did everything both of you mentioned and nothing seems to work for me.

Even by right clicking the the game and selecting which GPU I want to run it on, it still defaults to GPU 0, which is Intels dedicated card.

I guess the game is so old it simply wasn't programed to work with multiple GPU's, it automatically defaults to GPU 0 which is always the integrated one. The only solution would be to somehow remap the GPU's on a system level, and I have no idea if that's even possible...

Signature

Navigator, tools, guides and much more!
Visit us at: http://thepiratescove.org
#4
Posted on 2019-03-28 08:55:24 | Show thread starter's posts only

Problem

VCO being run on notebooks with multiple graphic cards, under Windows 10 will automatically be ran on integrated cards instead of a discrete ones. This causes huge FPS drops as integrated cards generally have less processing power than dedicated ones since they aren't really made for gaming.


Cause

The main cause of this problem appears to be NVIDIA® Optimus™ technology. This technology comes packed with NVIDIA® graphic card drivers. The main purpose of it is to enhance notebook battery life, by trying to determine whether the application being run would benefit from the discrete GPU. If not, it disables the discrete GPU and runs the application on the integrated one to conserve power.

The issue stems from the fact that Optimus™ will run all DirectX8 (or lower) based applications on integrated GPU, regardless if the notebook is on battery or not. Whether this is a bug, or intended behavior is not quite clear. All I could find is this question on NVIDIA support page which indicates that indeed it is expected behavior.

Since VCO is a DirectX8 based, it will only run on integrated GPU.


Solution

The solution of this problem consists of two things.

1. Force VCO to run on discrete GPU.
This can be done by opening NVIDIA Control Panel:
Hit Windows Start button > Write nvcplui and hit enter

Once the panel opens, navigate to:
3D Settings > Manage 3D Settings > Program Setings tab

Next step is to create custom settings for VCO
Click Add button > In the popup window click Browse > Navigate to ..Voyage Century Online\voyage and select Core.exe then click Open

Last step is to select the preferred graphics processor:
From the dropdown menu select High-performance NVIDIA processor > Press Apply button to save changes

Here's a preview of the control panel settings..



2. Wrap VCO in DirectX10 wrapper to trick Optimus into thinking you're running a DirectX10 game.
This can be done by installing dgVoodoo 2. Installation procedure is documented on their website.

In case its too complicated, I've made a .zip file to make installation process easier.

Windows 10 installation guide

1. Download the .zip file from google drive link found in this post.
2. Right click one the .zip file, click on Open with and then on Windows Explorer.
3. Once a new window opens, click on Extract all files button which is located at the top.
4. A new window will open that will ask you where do you want to extract these files. Click on Browse and locate your Voyage Century Online folder. After your found your folder, click OK.
5. Uncheck the Show extracted files when complete button.
6. Click Extract button.

Download from:

GPU Fix on Google Drive

Signature

Navigator, tools, guides and much more!
Visit us at: http://thepiratescove.org
#5
Posted on 2019-03-28 17:40:19 | Show thread starter's posts only

Godlike! For the first time , I saw in task manager the dedicated graphics getting used . But I have a question now. If i run 2 accounts either with dedicated either with "high performance nvidia card" on the high speed or high quality settings from game, in both cases it still uses 50 % for 1 account and 100% for 2nd account. This means my dedicated is bullshit and should i leave it as it was for yeaaars and use the integrated? Or is still better this way? My integrated is called Intel HD graphics 510 and dedicated is called Nvidia geforce 920 MX. Thank you in advance

Signature
If you really want something, you gotta do everything in your power to achieve it and if that is not enough , then you gotta do what is required.
#6
Posted on 2019-03-28 22:48:16 | Show thread starter's posts only

If its showing as 100%, it means the game is using all the processing power that GPU can offer.

But it doesn't necessarily mean you have a shitty dedicated card. Windows has Power Plans which are managing the power consumption. There are three plans, Power Saver, Balanced and High Performance. They are supposed to be turned on and off depending on the notebook usage. For example if you're not playing anything and you're not plugged in to the mains AC, then you probably want to choose Power Saver to limit the battery drain as much as you can. If you're plugged in to the mains AC and you're gaming, then you would probably want to select High Performance

Different power plans have different presets which will automatically, for example, underclock CPU and GPU, so it doesn't use as much power. If the CPU or GPU are underclocked, they will perform slower so your game might lag.

So always make sure you have the right power plan selected. If you're gaming, make sure you select High Perfomance.

Although nothing comes without bugs. I discovered that when I use Voodoo, even if I select High Performance, if I'm not plugged in, if I'm playing on battery, my dedicated GPU will still be severly underclocked and the game will lag to the point of it being unplayable. Performs much worse than integrated card. As soon as I plug into the mains AC, everything works as expected.


So in short, if you use Voodoo, make sure you select High Performance power plan and make sure you're plugged into the mains AC because the game might perform even worse than on integrated card.

Signature

Navigator, tools, guides and much more!
Visit us at: http://thepiratescove.org