Voyage Online Today: 4    Total Posts: 83075

Total:#6

Create Thread

[Discussion] Problems with payments

[Copy link] 5/209

#1
Posted on 2017-09-11 15:50:59 | Show thread starter's posts only

Anyone else have problems with buying IM lately? I use Amazon Pay all the time in the past and now it never works for me anymore. I try multiple times and it never loads anymore for me to login and confirm payment it just freezes at loading screen. I've sent ticket in to service center and they say nothing is wrong. I've tried multiple browsers and devices and nothing changes. Just curious if others have issue?

Signature
#2
Posted on 2017-09-11 21:43:52 | Show thread starter's posts only

There has been several issues lately where some players didn't receive points after purchasing, but I haven't heard of an issue like yours before.

I never purchased anything via Amazon Pay. I am not sure how it works. What is your issue exactly?

Can you login to the Amazon page at all, or its not even loading the login page?
Could you give us the URL of the screen its freezing at?

When I'm trying to purchase, it does take me to the Amazon Pay login page, but since I don't have an account there, I can't go further.

Signature
Help us at Voyage Century Wikia!
http://voyagecentury.wikia.com

Check out various tools for VCO at The Pirate's Cove:
http://yourpiratescove.com
#3
Posted on 2017-09-12 04:45:25 | Show thread starter's posts only

This is as far as I can get.  It just freezes here and won't go to the amazon login so I can put in my info and confirm the payment like it should.

Signature
#4
Posted on 2017-09-12 10:34:55 | Show thread starter's posts only

That page is supposed to redirect you to the Amazon Pay login page. It successfully redirects me. I am not sure why it doesn't work for you.

Do you have any addons on your browser that might be disabling redirects or javascript (noscript or adblock)? Do you have any antivirus online monitor that might be disabling redirects or javascript?


Have you tried clearing browser cache? (CTRL+SHIFT+DEL)
Have you tried flushing dns? (open cmd and write 'ipconfig /flushdns' )




Edit:
I see you said you tried using multiple browsers and devices. Have you tried using multiple networks? Maybe your home router is somehow blocking it?

Signature
Help us at Voyage Century Wikia!
http://voyagecentury.wikia.com

Check out various tools for VCO at The Pirate's Cove:
http://yourpiratescove.com
#5
Posted on 2017-09-12 15:51:01 | Show thread starter's posts only

I have a similar problem with the website since the hacker attack. I cannot access the main website via any device (phone, desktop, laptop) that is connected to my home wifi. Any other wifi or just on cell signal, I can load the site just fine. I'm guessing the hacker attack was a DDoS and in the process of stopping it, they likely banned a few IPs or MACs of people that were trying a bunch of times to load the website when it was getting attacked and consequently were flagged as attackers themselves. I know I kept trying to reload the page a bunch of times in different browsers during the attack (at the time I wasn't aware of the hackers attacking)

I tried to reset my IP and the website still refuses to load in any device using my home wifi, even devices I have never tried to access the website with.

Signature
#6
Posted on 2017-09-12 16:18:11 | Show thread starter's posts only

Try going to the Amazon Payments page and contacting Amazon support.
Maybe they can unblock you.

https://pay.amazon.com/us

Signature