Voyage Online Today: 0    Total Posts: 9139

Total:#6

Create Thread

[Magellan&Marco Polo] Bugged Labrinton

[Copy link] 5/331

#1
Posted on 2018-12-09 09:33:43 | Show thread starter's posts only

When i try to go Labrinton all times crash game and can't log in for next 20-30 min to any server.... 
Help me to repair it pls!

Signature
Ninja
#2
Posted on 2018-12-09 11:38:52 | Show thread starter's posts only

Have you tried reinstalling the game?

Signature

Navigator, tools, guides and much more!
Visit us at: http://thepiratescove.org
#3
Posted on 2018-12-09 19:02:21 | Show thread starter's posts only

Yes sir, but don't help….

Signature
Ninja
#4
Posted on 2018-12-09 20:53:41 | Show thread starter's posts only

I have been having pretty bad connections myself...  the colored bar often turns red... its almost the holidays in the USA and this seems to happen around this time of year...

What was your connection like before you crashed?
were you running other accounts and or other programs?

Have you done Labrinton before and do you usually lag then?

I don't suppose you are already using a VPN...  sigh

not a lot we can do....  its a cursed game I swear.

- Ele

Signature
#5
Posted on 2018-12-10 03:56:15 | Show thread starter's posts only

Connection yellor or green, 1or 2 account run same times, other program Explorer or nothing.
2 Year agoo worked Labrinton now not… same problem with Yizhou Bay, but there i can relog and near Lab i can't log in only when lab ended...

Signature
Ninja
#6
Posted on 2018-12-10 06:10:21 | Show thread starter's posts only

Muted  

Signature